0

This is a bit embarrassing, but it appears that the OpenID button that allows you to log in with a WordPress.com username is not working. I'm not sure if this is on SE's end or on WordPress.com's end, but it will cause problems.

Remember, there was a significant amount of tension between the existing WP community and the WPA community when we first pitched the idea. I don't want this to be seen, even subconsciously, as a further disconnect between WordPress.com and WordPress Answers.

What can we do to address the problem as quickly as possible?

For the record, this was pointed out to me by another developer via Twitter this morning. I immediately logged out of WPA and tried to log back in via WordPress.com but received an error:

Unable to log in with your OpenID provider:

No OpenID endpoint found.

I verified that http://ericmann.wordpress.com does exist. And this is the appropriate way to use WordPress.com's OpenID system according to their FAQ. I hate to ask, but could they be blocking OpenID requests from SE?

| |
5

... and ... I just answered my own question.

It appears that WordPress.com blocks OpenID authentication for "private" blogs. So if you set up your account to use a service like Akismet and didn't want a blog (i.e. "just give me a username") your blog is marked as "private" by default.

To fix this, you need to log in, go to your main site's dashboard (your main site is http://username.wordpress.com) and change the privacy settings to at least "Allow normal visitors."

After this change, OpenID authentication works just fine.

But we should still be aware of comments like:

Strange how I can't log into https://wordpress.stackexchange.com/ with my WordPress.com account...

Some people read more into that issue than they should ...

| |
  • 1
    good tip -- I wondered about this, since WordPress does work as an OpenID provider and always has, but clearly you need a public blog for it to work. – Jeff Atwood Dec 29 '10 at 21:34
  • And unfortunately the "public" part is left out of much of the documentation. The user who originally alerted me to the problem already had an account (like me) that was used purely for API purposes - i.e. they had a "private" blog and couldn't use OpenID. I helped them make it public and voila, they're now a happy SE user as well :-) – EAMann Dec 29 '10 at 21:52
0

In case anyone had problems logging in via their WordPress.com OpenID at the end of January 2010: there was a problem on their end, but it seems to be fixed now.

| |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .